PHP is one of the most widely used general-purpose server-side scripting languages. It’s exceptionally popular since it is free software, which can be used to develop responsive sites such as social networking websites, online shopping portals or e-learning websites instead of static HTML sites. A PHP module must be available on the web server where a PHP site is hosted so that its source code can be ‘deciphered’. As there aren’t any license charges for this sort of module and the language provides countless possibilities for the Internet applications that you create, there are hundreds of millions of PHP sites. What’s more, there’re plenty of PHP-based scripts, which you can use for your sites without needing to possess any programming skills. Given the fact that there’re a couple of versions of PHP, you need to ensure that the very same version that you used whilst building your site is installed on the server as well.
PHP 4 and PHP 5 Support in Cloud Hosting
With our cloud hosting, you’ll be able to pick the version of PHP that will be active for your web hosting account, since several versions are available on our servers. With just one click, you will be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and every time a new version is published in the future, we will include it in the Hepsia hosting Control Panel without removing the previous versions. In this way, you will be able to host all the websites that you have developed over the years. Unlike a lot of other companies, we will not compel you to update such websites, as a script may be out of date, but this doesn’t automatically mean that it is vulnerable since you may have performed modifications to its source code to prevent security gaps. For your convenience, you’ll even be able to choose a different version of PHP for each site hosted in your shared web hosting account.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
If you’ve got a site based on a previous PHP version and you’ve donated time and effort to developing it, repairing safety breaches and inputting web page content, you will need to find a hosting service that can support it, since nearly all web hosting providers today support only the most recently introduced version of PHP and abandon the older versions. We, however, have decided to permit you to pick the exact version that your own websites need. Our semi-dedicated servers support multiple versions of PHP 5 as well as PHP 4, so you’ll be able to use both newer and older scripts without forfeiting any custom modifications or wasting time striving to make your websites compatible with the web hosting environment. You can change the current version through the Hepsia Control Panel and such a change will apply to the whole account, but you’ll also be able to choose a different PHP version for each individual site hosted in your account by means of an .htaccess file.